When I turn off my Jandy SHPF1.5-2 pump water shoots out of the lid

  • 79 Views
  • Last Post 09 May 2019
Geokashers posted this 07 May 2019

Looks like I need some kind of ring and/or seal relacement? The one I have 'looks' fine and is lubed up but I'm guessing rubber just starts to fail after awhile so I should probably just replace the seal/ring? The rest of the lid looks fine to me.

Let me know what parts I should be ordering. Thanks!

John

Order By: Standard | Newest | Votes
Geokashers posted this 07 May 2019

I do have air getting into the pump and I've read online where folks talk about the lid being warped. The water is coming out between the clear 'window' on the lid and the black frame part. So the seal is certainly bad. Do the lids need replacing after a certain age? Or unit will be 5 years old in August.

Thanks!

John

 

InyoRob posted this 07 May 2019

The most common cause of water shooting out from the pump lid is a bad lid o-ring. The pump lid o-ring for the Jandy Stealth SHPF1.5-2 is part number 5020-135.

If the problem persists after replacing the lid o-ring, the actual lid may need to be replaced. The lid assembly is part number 5020-040.

Geokashers posted this 09 May 2019

I'm going to order the o-ring as you recommended. Do I also need to get some additional sealant/lubricant? I think I had that on the existing one. Just making sure I have everything I need.

InyoRob posted this 09 May 2019

We'd recommend using a little silicone or teflon lubricant on the o-ring.

Close