pool pump wont shut off

  • 1.8K Views
  • Last Post 20 September 2016
printer posted this 20 September 2016

I have a 2 HP hayward pump that wont shut off even in service mode.  I have to manually shut the breaker to the power.  Any suggestions why this is happening?

Order By: Standard | Newest | Votes
InyoRob posted this 20 September 2016

Hello Printer - The most common cause of the pool pump not shutting off at the control panel is a faulty relay. What is the make and model of the control system?

printer posted this 20 September 2016

 the system is about 12 years olf.  its a jandy system with a control panel in the house as well as the mail control panel outside.

If i put the mode in service mode, the pump still stays on and have to shut the breaker. 

InyoRob posted this 20 September 2016

If it were colder I would say that the freeze protection might have kicked in but we are not quite there yet weather wise. It sounds like you have a relay issue. The pump relay for the Jandy control system is part number R0658100

Hopefully this helps. Thank you for shopping with INYOpools.com!

printer posted this 20 September 2016

 where would I find the exact part inside that panel.  If i remember the relay doesnt look as big as the item number you sent me

printer posted this 20 September 2016

 I actually just went out to the control board and hit it a couple times and it works now.  I guess something is loose inside

InyoRob posted this 20 September 2016

It could be something loose but more than likely its the relay. Tapping a bad relay will do the same thing. If you open up the control panel and remove the panel that covers up the cables, you should see the relays.

Close