Just replaced Caretaker 5 port infloor assembly - only half pool cleans

  • Last Post 11 November 2020
  • Topic Is Solved
we5inelgr posted this 10 November 2020

Hello, I recently replaced our Caretaker 5-Port Complete 1.5" Water Valve Assembly, CARETAKER SKU: 5-9-2000.  To do this, I had to cut out the existing assembly, and cut out the existing pipes leading into the assembly and the assembly's removable section to get to the little metal pre-filter.


I finished installing it yesterday in our existing pool, with existing infloor system from about 15 years ago.  So this was a replacement of this 5 port valve assembly only (not a new system).   I turned the pool pump on and all seemed well for about a cycle or two.  Then, it seems like about half of the infloor pop ups are not working (not fulling extending up). There are no water leaks from what I replaced and there is no grinding or other noises coming from the new assembly.  It runs quite.   I removed the filter that sits atop the assembly, there was only very very minimal amounts of pvc pipe cuttings.  Prior to installing the new assembly, I used a wet dry shop vac to vac out any debris from the 5 pipes going to the pool so there should not have been any debris from assembly forward at that point.  After removing the minimal debris from the filter before the assembly, I ran the system again.  Same thing.  After about an hour, it was clear that about half of our infloor nozzles were not cleaning the bottom of the pool, so about 2 or 3 ports not working.

Our pool cleaning pump is 2.5 hp VS. I'm currently running it at max 3450 rpm (for catch up cleaning purposes, mainly dirt, no leaves or big debris).

The pool filters pressure is a pretty constant ~35 psi.

The caretaker pressure gauge on the 5 port assembly dome ranges in reading from ~30 to ~40 psi. When it's cycling to the infloor nozzles that are popping up and working as expected, the psi is around 40. When it's cycling to the nozzles that are not popping up all the way (about 1/2 way or less), the psi is around 30. There are no nozzles that do not pop up, at least partially.

I'm also noticing some air bubbles continue, after initial start up, through each cycle and coming from each nozzle (whether it's fully popping up or not), but then the bubbles go away after about 10 seconds or so.


Any ideas on what might be going on and how to remedy it?   Thanks.

we5inelgr posted this 11 November 2020


Turns out, there was some very small plastic cuttings that got past the dome filter and were causing issues with the gears inside the assembly.

I removed the top part of the assembly, but did not open it like one would do for a rebuild, and simply used a garden hose to spray water inside, swish around dump out.  Rinse, repeat several times.

Once cleaned out, the new assemble works as expected.

  • Liked by
  • InyoRob