Hello all,

My first time here so thank you for taking the time to read. 

my Pentair master temp 400 was not working when I went to use it for the first time this season. The display light for Check System is on, and so is Spa On. Checking the back board HPS LED is lit confirming the board thinks there is a Pressure switch issue, but I have taken those leads off and shorted them and not seen any change. 

Also of note the temperature readout says 99 and while the pump is running it will occasionally flash to 91 then back to 99. None of the buttons cause any response whatsoever. I've tried holding buttons for 3-5 seconds and it's as if it's frozen. I tried disconnecting the thermistor and it does jump to a e01, but then that does not clear when I reconnect it unless I power the unit down and back up. 

I tried replacing the thermistor in case that was what was sending the 99degrees but that didn't change anything at all. 

my next thought is the control board is bad but I am hoping to get any ideas from you kind folks before taking a $400 stab in the dark.