Leak after replacing motor and seal

  • Last Post 25 April 2020
GregHouston posted this 24 April 2020

I just purchased a Century B2843 motor and GOKIT32 kit for my Pentair Whisperflow WFE8 pump.  I replaced the shaft seal, the seal plate gasket and the diffuser oring.  I followed your video for the shaft seal and had no problems with it.  The seal plate gasket was difficult to fit in the groove, but eventually stayed in. 

After reassembling, I have a small leak with water seaping out at the bottom - only when the pump is running:




What's causing this, the shaft seal, or the seal plate gasket?  Could the new shaft seal be bad?




Order By: Standard | Newest | Votes
MERDR1 posted this 24 April 2020

I am about to do a similar process with my pumps and want to make sure I do not create any more problems. Did you use any silicone seal lubricant etc. or was the seal loose fitting as you said finally go it to stay in implying a loose fit? If you would please let me know ( thru this forum) how things worked out and what the problem was. My first motor was destroyed by a similar leak but above the pump and salt water ran down into the Hayward superpump right where the motor attaches to the pump housing and due to a very poor design (not just my opinion) ran right into the forward cooling vent of the motor. You can write the rest of the tale yourself. Trying to avoid that with the new variable speed motor by adding the new viton salt resistant seals in both pumps (second for the polaris and a third for water features) and dumping the salt system for an as yet undetermined system. I also have a CoverStar automatic pool cover built into the pool and do not want that destroyed too (not related to pump leaking isssues).The water is very nice but not worth the cost of replacing everything every few years especiallly the cover as thats 1/2 the cost of a new pool (well kinda)!

Thanks for your post


GregHouston posted this 25 April 2020

- For the shaft seal, I used a small amount of 100% silicone caulk on the metal side, and used a 1" PVC coupling to push it into place, taking care to not get anything on or touch the surface
- The part that goes on the impeller pushed into place with no issues - I did not use any sealant or lube
- For the seal plate gasket, I first coated the gasket with the silicone lube that came with the GOKIT, then tried to push it into the groove around the edge of the seal plate, but it seemed too wide - I had to squeeze it in, and it kept popping out - I gave up and put the old gasket back in, though it was a bit rough at the bottom.  Initially, this seemed to work, but after a couple hours, it started to seep at the bottom.
- I tried again with the new gasket, this time cleaning off all the silicone and letting it dry. This helped, as it was less likely to pop out after squeezing it into place.  It took half an hour to squeeze it into the groove bit by bit, but eventually it stayed.  I coated the top with silicone lube and reinstalled.  This time water started to seep out immediately at the same place.
- I found a Pentair parts list which lists two different seal plate gaskets, an almond one used pre-2008 (which matched my old one), and a black one used post-2008 (which matched the new one).  They have different cross sections - the new black one seems a bit larger.  It's not clear to me if the new one is supposed to be used on pre-2008 models, but it came with the GOKIT32 - I didn't see another option.
- I found and ordered an old-style gasket on Amazon, along with a new shaft seal from U.S. Seal (it's not clear who made the seal from the GOKIT32) - most videos I've seen recommend the genuine U.S. Seal product.
- I'll try these when I get them.  I'd still like to know whether it's the shaft seal or gasket causing this type of leak - or possible something else?