WhisperFlo WF-8 impeller binding

  • 45 Views
  • Last Post 03 January 2022
Vabrook posted this 12 December 2021

I replaced the pump motor, shaft seals and other seals.  When adjusting the impeller tightness, the motor binds up and won't turn.  It seems like the shaft turning is tightening the impeller more as the motor briefly runs.  Is something missing or out of alignment?  Thank you.

Order By: Standard | Newest | Votes
InyoRob posted this 13 December 2021

I'd make sure both pieces of the shaft seal are installed correctly. Also, the impeller doesn't need to be overly tightened. Spin it on until it's firm. 

Which motor did you order?

Vabrook posted this 14 December 2021

I bought the B855 Century 2.0 square flange 56Y Up rate motor from Inyo.  

InyoRob posted this 14 December 2021

The B855 is a 2HP uprated motor with a total HP rating of 2.2. Your WF-8 Whisperflo would have originally come with a 2HP full rated motor with a total HP rating of 2.6. The original impeller would be rated for a 2.6 THP motor. Basically, the B855 motor is undersized to handle that impeller. 

One option would be to downsize the impeller. The correct impeller for the B855 motor is part number 5074-27C. I would uninstall the components to the motor and test the motor to make sure it's running ok before ordering the impeller.

The other option is to order the full rated 2HP motor. The part number is B2748.

Vabrook posted this 15 December 2021

If I downsize the impeller, will I also need a different shaft seal set than the one in the GOKIT 32 that I used?

InyoRob posted this 15 December 2021

The shaft seal and all other components would remain the same.

Vabrook posted this 31 December 2021

Rob, after waiting on the USPS to deliver the new impeller for 2 weeks, I installed it and it fit the motor and shaft much better.  I attached the volute and it bound up.  Does the volute need to be matched to the impeller as well?  Please help.  My pool looks like a stock pond right now!

InyoRob posted this 03 January 2022

There is only one option available for the volute. The part number is 350015. That volute has been used on the Whisperflo since 1998.

Have you tested the motor with the diffuser installed before you secure the motor assembly to the volute? If not, I'd test it to see if it is running ok. We don't usually see the volute being the problem but this could be a rare scenario.

Close