Sta Rite Maxi glass 2 capacitor

  • 598 Views
  • Last Post 02 September 2020
Curt96367 posted this 30 August 2020

I have a maxi glass 2 pump that has 2 capacitors on top.  I have been trying to fins a pump with 2 capatitors (even on the pentair site).  There is no model # on the pump at all.  The pump pumps a little waterfall and when its hot outside, it will run for about 3 minutes auto shutdaon and will then come back on about 30 minutes come back on.  So I am thinking the run capacitor (since there is 2 I am thinking 1 is start and the other is run).  

Order By: Standard | Newest | Votes
InyoRob posted this 31 August 2020

We'd be glad to assist you. Could you post a picture of the motor label that includes the specs?

Curt96367 posted this 31 August 2020

Curt96367 posted this 31 August 2020

These are all the pictures I can get.  I do think from one of the numbers its 3 HP.  It does pump for a waterfall ornament.  

Thanks!

InyoRob posted this 01 September 2020

The replacement motor is model SQ1302. The older version had two capacitors on top. The replacement now has one. Click Here to View More Details on the 3HP Max-E-Glas II Motor

We recommend replacing the seals when you replace the motor. The seal kit is GOKIT38.

Curt96367 posted this 01 September 2020

Thanks so much for the quick reply!!  How can I find the part number of the capacitor?  Are the start and run part numbers the same? I want to verify what I have in there are the actual proper ones.  The pump is old and who know what kind of work was on there before, so I would like to replace the same (proper) parts.  I looked at the details and couldnt find the replacement part number.

InyoRob posted this 01 September 2020

Unfortunately, I do not have the specs on the older motor and I'm unable to confirm the capacitors.

Curt96367 posted this 01 September 2020

Thats the problem I am having.  I cannot find anything on the 2 capcitaor type motors.  I guess I will have to tak the person who might have replaced them in the past (if they ever did), and use those replacement part numbers.  I am pretty sure my run capacitor is bad.  The pump will run for about 30 minutes or so then then will shut off.  Let it stay for about 30 minutes and it will come back on....

Thanks again for the help!

InyoRob posted this 01 September 2020

Are you able to read the specs on the capacitor? Let's say the run capacitor is 30MFD and 370V. You could go with a 30MFD 440V and the capacitor should last longer. 

There is corrosion at the top and bottom of the motor. Rebuilding it may be a temporary bandaid. I would start looking at complete motor replacements.

Curt96367 posted this 02 September 2020

Copy all....I did take the capacitor covers off, and I took a picture of the capacitors....I am trying to do a search.  It did confirm my suspicion, that one of the capacitors were replaced at some time in the past.  How do I know which one is the start and/or run?  The green one was on the left side (from the earlier picture).  Not that it matters I will replace both of them...

InyoRob posted this 02 September 2020

The white label is the run capacitor and the green label is the start capacitor.

Curt96367 posted this 02 September 2020

Copy Thanks!!  I am going to take these capacitors and see if I can get them locally.  The start (green one) when I did a search coulnt find any that werent coming from "China"....so I will take to an expert and get a suitbale substitutute 

  • Liked by
  • InyoRob
Close