Pump Low Flow and Pressure

  • 1.4K Views
  • Last Post 14 September 2021
pwmiller posted this 11 September 2021

My Jacuzzi 1UMF-S pump has low flow and low pressure.  For this issue, I have ruled out all causes external to the pump.  I have cleaned the pump internals including the impeller.  The impeller is in good condition.  What pump parts do I need to service to correct this issue.  Thanks.

Order By: Standard | Newest | Votes
pwmiller posted this 12 September 2021

Did some more work on this pump.  When I restrict the flow on the discharge line, the pump flow and pressure raise quickly to normal levels and maintains good flow and pressure after the restriction on the discharge line is removed.  Not sure what to do next.

InyoRob posted this 13 September 2021

We'd be glad to assist you. Are the valves before the pump open so that the pump can pull from the skimmer and main drain? It's possible that the pump is struggling to get enough water to fully prime.

Here is a video regarding other plumbing issues that can lead to priming problems.

pwmiller posted this 13 September 2021

There is a diverter valve so the pump can pull from the skimmer or the bottom drain. I have spare pumps (Hayward SP3007X10A and a Jacuzzi 1MAG-U-S). I have swapped both these pumps with the Jacuzzi 1UMF-S (the pump with low flow and pressure).  Both the Hayward SP3007X10A and the Jacuzzi 1MAG-U-S work fine.  All pumps are 1 hp.

InyoRob posted this 14 September 2021

The issue has to be something in the pump. The motors don't slow down over time, so we can rule that out. You mentioned that you opened up the pump and cleaned out the impeller. The impeller was in good condition. We'll assume that the diffuser was in good shape.

I'd start with replacing the seals in the pump, including the eye seal. The seal kit is part number GOKIT14. The eye seal is part number 5062-17

Close