Aqua Rite SWG not "Holding" Calibration

  • Last Post 12 September 2021
baa2019 posted this 29 April 2019

I have a Goldline Aqua Rite SWG manufactured after December 2008. I installed a brand new T-9 cell two and a half weeks ago. I took a water sample to the pool store and had  it tested. The salt reading was 3100-3200ppm. My pool is 19500 gallons. I have also checked the Ph, alkalinity, and stabilizer and they are all in range of what they should be. The pool store said my sample was "pristene" and that I was generating chlorine. I have recallibrated the generator numerous times and each morning when the pump turns back on, I have to recallibrate. This has been an on going thing each day. Once I recallibrate in the morning, it does fine the rest of the day. I have an automatic timer on the pump from 7AM to 7PM each day.  In the mornings when the pump comes back on, the reading has been as low as 1700ppm and the "check salt" and "inspect cell" lights are on. Any suggestions???

Order By: Standard | Newest | Votes
actxpools posted this 12 September 2021

Similar problem.  My old cell died (or so I thought) as it was reading very low. . .and not generating with a Salt Low message (it was 8 years old).  New cell put it and now reads high by about 1800 ppm.  Pool is at 3000 and it is reading 4800.  When I calibrate it it starts the count down and will only get to around 3600 (no lower).  I stop the process and it seems happy and is generating.  But a few hours later it is back to reading 4800 and Salt Hih light. .

Any ideas - just replace the main board?

figoveas posted this 03 September 2021

This is absolutely correct! After two years of suffering this very same problem with my Aquarite, and a few wasteful calls to good-for-nothing MFs at Hayward's tech support, I came upon this thread and your post today. Then it clicked to me that in my case while the wiring was in place accurately and connected in sync with the pump via a rotary dial timer, the ON and OFF trippers had fallen off the dial, due to which the damn thing had become 'connected' all the time. I just put the trippers back on to sync with the pump timings, and viola! Hope this helps someone out there... Thanks!

Service posted this 10 June 2021

Hi Kyle,

If you have replaced both cell and motherboard then this should be everything needed. What is your current salt level? If your salt level is too low then sometimes this will cause the unit not to turn. I would also suggest going through this step-by-step AquaRite Troubleshooting Guide it's possible you may have a bad transformer.

Thank You


Kyle1974 posted this 07 June 2021

After 2 weeks of searching, I finally came across this thread.  I am having the exact issue as the OP, and also have a T15 cell. 

in the last couple weeks I've replaced the cell and put a complete motherboard in. Was there ever any resolution for the original posters issue? 

it's almost comical as I'm also about to go on vacation. Serious deja vu!  

Samysapphire posted this 08 June 2020

I had the exact same problem where my Aqua Rite controller would not hold calibration as described above.  I found that the installers had connected the controller to the panel for constant powering.  This IS INCORRECT and should be powered by the timed pump curcuit.  This resolved the loss of calibration and was very easy to correct.  If you have external computer controls for your system it needs to be constantly powered.  As a stand alone system it wants to be powered on and off with the pump.  This does two important things: 1) Maintains proper average salt reading since it is only counting the readings when the pump is on and the salt generator is operating (and not averaging all the time the pump is off ). This also prevents the system from producing numerous faults related to incorrect average readings., 2) The Aqua Rite reverses the electrical polarity to the salt generator each time it powers on and off to extend the life of the TCell plates. With constant powering this reversal does not happen unless manually shut on and off.

This blog helped me solve a problem that has been going on for three years with my pool with no good help from Hayward or my pool builder.  Kudos to InyoPools for providing some of the best videos and information for pool maintenance and setup!  Thanks.

  • Liked by
  • figoveas
Kannyn posted this 17 April 2020

Hi DJfontenot,

I have the exact same problem you had.  My pump does not reset, unless I do it manually.  I have a friend who can replace the Varister, but he is asking me a few questions.  I thought you might be able to help.

1) which Varister did you replace?  Is it this item with the red arrow?

2) How did you SET the Varister value when you replaced it?

3) where did you order the Varister from? Digikey or Amazon?

Thanks In Advance for any help you can provide.

InyoRob posted this 27 May 2019

That's great news! We appreciate the update.

djfontenot posted this 26 May 2019

Timer kicked on and all was well....thanks again!


  • Liked by
  • InyoRob
  • Kannyn
djfontenot posted this 25 May 2019

Thanks rob, was able to buy varisters that blew out on motherboard and fixed both of them for $1.59 a piece.  Got everything up and working so far, have to wait till timer kicks on tomorrow and see what happens with salt level. Thanks a bunch!

InyoRob posted this 24 May 2019

The connections at the Aquarite board should look like the image below. One "hot" line is on terminal 1 and the other is on 4. The jumpers are on terminals 2 and 3.

Guide Step Image

The Aquarite should be wired to the same terminals as the pump in the timer box. This would be the load connections. The idea is that you want the pump and Aquarite to turn on and off at the same time. 

djfontenot posted this 24 May 2019

Have LR3730 timer, 240 volts.  Wire on number 1 and 4 in the chlorinator box. Wires on 1 and 3 in the timer box which is lines, not load. And jumper on 2 and 3 in the chlorinator box.  Is this right, cuz I have blown my old PCB and the new PCB board  trying other variations.  When I have it this way as described above, my salt level is calibrated to 3100 as reported by the pool store, but as soon as the timer kicks on the next day, it drops to 400 or 1500, 0r 1700.....this was all with new pcb board and new T15 cell, and yes again my cell T15 was set  right on the display, and yes again my AL-0, and held button for 5 seconds to reset 500 hours etc....Before I buy a new pcb board frpm you, I need answers from you.

djfontenot posted this 23 May 2019

OK I put my jumpers to 1&2 and one to 3&4...... So do my wires from the chorinator go to 1 and 3 post in timer?  my pump goes to 2 and 4 in the timer.....when i put the chlorinator on 2 and 4, the same as my pump, it blew the new board.

InyoRob posted this 23 May 2019

The connections for 230v in the Aquarite are 1 and 4. The jumpers are on 2 and 3.

It sounds like your issue is an anomaly. The steps and guides that are linked above solve 99% of the issues with Aquarites.

Listed below are a few of the authorized Hayward servicers in your area.

All Seasons Pools & Spas 337-983-0025

Voodoo Pools 337-298-0980

The Pool Guy of Louisiana 337-298-4746


djfontenot posted this 23 May 2019

zip is 70503...was hoping to avoid this as it is about 300-500 to come out and i am on social security check. I show 240 volts. wires are on 1st and 3rd input to timer box and pump is on 2 and 4 output.  Jumpers are on 2 and 3. Green to the ground although previously it was never connected,  and previously the jumpers were to 1-2 and 3-4, but book says if 240 volt then it should be on 2 and 3


InyoRob posted this 23 May 2019

We would recommend contacting a Hayward service center and see if someone can come out and inspect the unit. If you can provide your zip code, we can look up an authorized service center that specializes in Aquarite repairs. 

djfontenot posted this 23 May 2019

The salt level has been checked numerous times by the pool stores with machines and manually.  It is 3100 and runs fine till the next day when the timer kicks in then it shows a low reading and check cell and minerals.  When it recalibrates it stops on 3100 and runs fine till the next day when the timer clicks on....and the process just repeats everyday.  Stop giving a lot of bull, I have it set at AL-0, i have the t-cell set at t-15.  I have had the salt level checked professionALLY.  The motherboard is new, the salt cell is new. the temp of the water is 85.  Have done the 5 second reset nummerous times.  The flow of my 40,000 gallon pool has been fine since built in 1994, so thats not the cause.  Have never changed the size of my pumps.  So your step one, step 2, and step 3 above have all been done.....very frustrrated that none, not even you can tell me what is wrong....not even hayward.


InyoRob posted this 21 May 2019

Manually test the salt level of the water and compare that against the salt level reported by the unit.  The unit will stop generating when the level falls below 2400 ppm.  When the average salt level falls below 2700 ppm then the operation may be intermittent because the instant salt might be varying by plus or minus 300 ppm.  That would cause the 'Check Salt' and 'Inspect Cell' LED to turn on.  I would not consider adding salt to the body of water unless I was certain that the manual test results were reliable. Keeping the salt level between 3000 ppm and 3400 ppm is more reliable than keeping it between 2600 ppm and 3000 ppm.  

Also, water flow may be sufficient to allow the unit to run by activating the flow switch, but may not be high enough to fill the cell continuously with water.  If only 2/3rds of the cell plates are covered with water containing 3000 ppm salt then the cell may continue to report 'Check Salt' and 'Inspect Cell'.  

If the 'Inspect Cell' LED is flashing and the average salt reading is above 2700 ppm, then the 500 hour cell countdown timer is active.  After the cell is thoroughly cleaned or has been replaced then press and hold the Diagnostic button for 3-5 seconds to reset the timer for the next 500 hour cell countdown timer.

djfontenot posted this 20 May 2019

I have the same exact problems and hayward was no help at all, can't even speak to someone. I am so tired of recalibrating everyday and fixing to go on vacation for 10 days...guess it will be green when i get back as no one seems to be able to help...not you and not hayward.  I too have new motherboard, new salt cell t-15.  Motherboard is set to AL-0, and to t-cell15, temperature is makes chlorine just fine when i recalibrate it but next day when timer comes on it shows low reading, makes no chlorine. tells me to check minerals and new cell.  Can't someone help???



InyoRob posted this 02 May 2019

The symptoms you are describing are not typically the result of a bad current limiter. However, it would hurt to look at the board and see if there is any noticeable damage to the limiter.

If the limiter looks ok, we'd recommend contacting Hayward tech support directly. 866-772-2100.

baa2019 posted this 02 May 2019

I have gone over all of the suggestions above. In the beginning, I thought that it could have something to do with the water temperature, but that does not seem to be the case because the water temperature yesterday was up to 85 degrees. Second, the AuqaRite is set on AL-0 for operation. Third, it is set for T-Cell 9. With that being said I have tried the following....

Instead of letting the pump run for only 12 hours, I ran it for 48 hours straight. I checked it numerous times during the 48 hour period. It ran just fine. It held the reading at 2900-3000ppm. The only lights on were "power" and "generating". Since the problem seems to be when it shuts off at 7pm nightly and will not reset when it turns back on at 7am, I turned it off for one hour (during the 48 hour period) and left it off just to see if it would reset when I turned it back on one hour later. It did!! So I set the timer to shut off last night at 7pm. At 8am this morning (after the pump had been on for an hour) I checked it and it showed 1700ppm, "power, check salt and inspect cell" lights were on. I am at a loss. I am familiar with the "current limiter" on the PCB, because we have had to replace that in the past due to faulty readings. Could this possibly be the problem?

Show More Posts