Weak Spa Jet pressure

  • 137 Views
  • Last Post 2 weeks ago
ScottAugerinos posted this 19 September 2021

My in ground pool and spa was working fine. I used to close pool return and pool suction and get enough pressure in my spa jets. The other day i closed the valves to divert everything to the spa and the jets are not strong like they used to be and it is like bath water now. Not sure why the jets would not have as much pressure anymore when I close of the pool valves and suction. 

Order By: Standard | Newest | Votes
ScottAugerinos posted this 19 September 2021

PSI is at 20 when it is diverted to pool and 22 PSI when it is diverted to spa. It used to be like a 5 PSI difference when it worked fine

InyoRob posted this 20 September 2021

I'd double-check and make sure all of the valves are open that divert water to the spa.

Have you cleaned your filter recently? If not, a dirty filter can slow down the flow of water.

Is the pump fully primed? There should be no air in the pump strainer. 

ScottAugerinos posted this 20 September 2021

Hi Rob,

The pump is fully primed and I have one valve for spa suction and one for spa return. They both are diverted to flow to spa. I will try and clean the filters today and see if that makes a difference. I hope it does because it does not make sense to me what is going on!

ScottAugerinos posted this 20 September 2021

I just cleaned the filter and still the same issue

ScottAugerinos posted this 20 September 2021

Do you think the diverted valve for pool/spa return has gone bad?

InyoRob posted this 21 September 2021

You'd see water returning to the pool if the diverter on the return side was bad. Can you post a picture of your equipment pad so we can see the plumbing?

ScottAugerinos posted this 21 September 2021

System

Raheem posted this 22 September 2021

 There is zero or little pressure coming from your jet nozzles, an air pocket may have formed in the line. This is known as an "air lock" and it will disrupt normal operation of your jets.

 

NomNomNow

InyoRob posted this 22 September 2021

Is the pump to the far right the jet pump for the spa jets or other water features? If it's for the spa jets, is it running and fully primed (water all the way to the lid and no air)?

My first thought is that the main pool pump is running and pushing water to the spa but the jet pump is not working correctly. That would explain why the water is hot but the pressure from the jets is not as strong as usual.  

The plumbing example below is closer to what you have.

ScottAugerinos posted this 22 September 2021

Rob - the pump on the right is for the water fall. The main pump is for pool and spa. The original picture you sent is how my setup is   

InyoRob posted this 22 September 2021

I don't see any in the picture, but are there any check valves on the return side of the system? There is often a check valve on the line going to the spa. This would prevent water from draining out of an elevated spa, back to the pool. It's possible that a check valve could be broken and not opening up fully.

It could be a clogged or damaged impeller. That would cause the pump not to push as much water.

Outside of that, I can think of much else. We've concluded that the filter is clean, the valves are set correctly, and that the pump is fully primed. We're also assuming that there are no return side or pressure side leaks. 

ScottAugerinos posted this 22 September 2021

I have a check value that is on a pipe underneath the pool/spa check value. I was wondering if it was not opening the full way. How can I tell? I see it close but when it opens I don't know how far it should be

ScottAugerinos posted this 22 September 2021

The check value is on a pipe underneath the pool/spa return line pipe. 

InyoRob posted this 22 September 2021

It depends on the style of the check valve. Some have union nuts on either side. You can unscrew the nuts and look inside the check valve. You can push the spring-loaded piece and see if it pushes all the way open.

Flo Control White Check Valve 2" - 1/2 lb. w/ Unions - 170020

The other style is called a swing valve. The tops on those can be removed in order to see if the flapper swings back and forth.

Custom Molded Products CMP Check Valve 1-1/2" Inside 2" Outside 2 Lb. Spring - 25830-704-000

 

ScottAugerinos posted this 26 September 2021

I changed the check valve flapper and still having the same problem. I do notice when I turn the pool/spa return valve to close the pool side I can feel some force and when I close the spa side I can't feel the same. Any thoughts?

ScottAugerinos posted this 26 September 2021

When the pump is turned on

InyoRob posted this 27 September 2021

If water is still returning to the pool when the valve is closed, you should replace the valve internals or the complete valve. 

The diverter assembly on the inside of the valve would look something like this. You can see a gasket on the diverter. That may have gone bad in your valve.

Jandy Diverter Assembly Neverlube (2-Way/3-Way) - 4720

ScottAugerinos posted this 27 September 2021

Would this have anything to do with my issue though

ScottAugerinos posted this 28 October 2021

This issue is still not resolved. Do you think my motor may not be as strong as it used to be and I need a new motor?

ScottAugerinos posted this 28 October 2021

Also my chlorinator has started to make a clicking sound when the pump turns off. It starts clicking when it goes off and will go all night until the pump turns on next day. Think this is related? I am baffled 

InyoRob posted this 28 October 2021

The motor does not weaken over time. The more likely cause would be a damaged/worn impeller and diffuser/diffuser gasket.

Again, this is assuming everything else in the system is ok.

  • Clean Filter
  • No Suction Side Air Leak
  • No Pressure Side Leak
  • Appropriate Valves are Open/Closed
  • No Clogs in the Lines
  • Proper Water Level
  • Clean Pump and Skimmer Basket
  • Check Valves are Working Properly

Henry234 posted this 2 weeks ago

I've recently filled my hot tub and there was little pressure coming from the jet nozzles. I surfed the Internet and looked through the Barefoot Spas reviews on this site. It was said that an air pocket may have formed in the line. This is known as an airlock. When jets start failing, the most likely cause is that your hot tub pump is not working correctly. So, I followed the advice found there and opened the access panel and the airlock valve close to the pump. This releases air from the line and purge system, allowing more water to stream through the jets. It worked for me. By the way, clogged filters or water intakes can also cause jet issues.

Close