Strange pump problem

  • 21 Views
  • Last Post 04 June 2019
  • Topic Is Solved
MarkGrantom posted this 03 June 2019

I installed a ECM27CU Variable speed pump 2 years ago on my Hayward pump body.  I have been very pleased with the performance up to this point.  I recently began noticing that the pump was just not pumping correctly when the polaris seemed to not have the same power as usual.  (It has the separate booster pump, but it is fed from the main pump.)  I realized that the main pump is turning on at the scheduled time, but after a short while it will fail with a "Prime Failure".  When I unscrew the main pump cover and prime with a bucket of water or hose, it will begin to pump, and will fill the main pump up to the lid, but after a short while it will lose prime.  I have disassembled the motor and pump and the impeller is not cracked or stopped up.  (I blew it out with an air hose.)  The main o-ring on the lid looks fine and there have been no changes to any of the 2" pvc plumbing coming into the pump which is attached with a 2" quick connect.  I also replaced the mult-port valve gasket and o-ring. I am begining to think that maybe I have some sort of blockage in the suction line.  I even tried running a garden hose from the pump volute back into the 2" pvc but of course I can't go very far with the hose.  I am completely at a loss as to what is happening.  Any suggestions would be greatly appreciated.

MarkGrantom posted this 04 June 2019

Once again, I am responding to my own post here because I found the solution to my own "problem".  Apparently, when I had my pool replastered with a different tile design, it changed the reference point to the correct level of water in my pool.  I THOUGHT I had the correct water level in my pool and that my skimmer was sufficently full but it turns out I was wrong.  The pool was trying to prime and in the process it would suck all of the water out of the skimmer and since the water level was too low, it was pulling air instead.  I increased the water level and now the pump does prime!  I only realized this when the pump lost it's prime and I ran over to the skimmer at that exact moment and saw what was happening.  Duh!  Still love this pump and it has saved me a bunch of $$!

  • Liked by
  • InyoRob
Close