Pool Pump Tripping Breaker

  • Last Post 15 July 2020
  • Topic Is Solved
ScottC posted this 22 March 2017

Hello. November 2016 I purchased the PL2102 - 1 HP Pool Motor Square Flange 48Y. Installation was simple and the pump has been operating approximately 4 hours a day since with no problems. This past Sunday (03/21/17) I noticed the pump wasn't running. After checking the switch at the timer and the wall switch I realized the breaker was tripped. I reset the breaker and turned on the pump at the timer. The pump started for a second and a large spark and pop came from the back side of the pump where the vents are. I reset and tried again with the same result. I took the cover off the back and noticed no burnt wires and couldn't see anything abnormal through the vents. Could the capaciter have gone bad? How can I tell? ... Am I still under warranty?

My info: Order Number: 714266    Date: 11/25/2016

Any help is appreciated, thank you!


Order By: Standard | Newest | Votes
InyoRob posted this 22 March 2017

Hello Scott - Sorry to hear your motor is not working. We'd be glad to assist you. Unfortunately, it doesn't sound like a capacitor issue. The motor needs to be replaced. It has a one year warranty. Contact our customer support at 407-834-2200 or the Support Request page. They can take care of the warranty replacement.

  • Liked by
  • ScottC
ScottC posted this 22 March 2017

Thank you for the quick response. I'll do that.

ScottC posted this 29 March 2017

It was a warranty issue. When I spun the motor by hand, it sounded like a chunk of something broke off and was rattling around inside the housing. I sent the motor back per your instructions and a new one was sent out the same day. I received it yesterday and will install tonight. So far, so good. Thank you very much Inyo Pool staff, particularly Megan.

InyoRob posted this 30 March 2017

Thank you for the feedback, Scott! We're glad to hear this was resolved quickly. 

Twisted01 posted this 15 July 2020

What indicated that the motor needed to be replaced? I'm having the same issue. I reset the breaker and when I turn the pool on at the timer switch, it immediately trips. A pop is heard and a tiny plume of smoke comes from the vents at the bottom of the motor. Is it something in the coil, inside the motor?


Thanks in advance,